Sunday, April 7, 2024

Cisco 107 - Inter-VLAN Routing via SVI (Switch Virtual Interface)

Jeremy introduces the concept of an "SVI" = Switch Virtual Interface in this video.  This is useful on a Layer 3 (Multilayer) Switch -- a switch that can also do layer 3 work (incluing routing).

First Jeremy removes VLAN config from router R1:

Remove the sub-interfaces:
R1(config)#no interface g0/0.10
R1(config)#no interface g0/0.20
R1(config)#no interface g0/0.30

R1(config)#default interface g0/0
^Resets the interface to its defaults

R1(config)#do show ip interface brief
^
View the config of R1 interfaces

R1(config)#interface g0/0
R1(config-if)#ip address 192.168.1.194 255.255.255.252
^Sets an IP address on R1's g0/0 interface

---

Now Jeremy reconfigures switch 2 (SW2) as a multi-layer switch and configures it to do VLAN routing.

SW2(config)#default interface g0/1
^Reset interface g0/1 to defaults

SW2(config)#ip routing
^Enables layer 3 routing on the multilayer switch

SW2(config)#interface g0/1
SW2(config-if)#no switchport
^These two commands change int g0/1 from a layer 2 switched port to a layer 3 routed port.

SW2(config-if)#ip address 192.168.1.193 255.255.255.252
^Since the interface is now a routed port, it needs a layer 3 IP address

SW2(config-if)#exit
SW2(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.194
^
These two commands tell SW2 to use R1 as its default route.
The IP address 192.168.1.194 is SW2's "next hop" and that IP address matches the one assigned to R1's connected interface up above

SW2(config)#do show ip route
^V
iews the route config on SW2

We can also see how an interface is configured to route with the command below.  Instead of showing a VLAN ID, the VLAN column will show "routed":

SW2#show interfaces status

Now we need to configure the SVIs (switch virtual interfaces) on SW2.
Create 3 SVIs and assign an IP address to each.  These IP addresses act as the "default gateways" to the PCs in the corresponding VLANs:

SW2(config)#interface vlan10
SW2(config-if)#ip address 192.168.1.62 255.255.255.192
SW2(config-if)#no shutdown
^This creates an SVI called "vlan10"
SVIs are shut down by default, so we have to turn them on

SW2(config-if)#interface vlan20
SW2(config-if)#ip address 192.168.1.126 255.255.255.192
SW2(config-if)#no shutdown
SW2(config-if)#interface vlan30
SW2(config-if)#ip address 192.168.1.190 255.255.255.192
SW2(config-if)#no shutdown

Recall that access or trunk ports on SW2 were already assigned to VLANs 10, 20, and 30.  So the switch has already created VLANs 10, 20, and 30.

 

[These are my notes from Jeremy's excellent CCNA course which can be viewed here.]